Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I sometimes struggle with Windows' weird file sharing. On the face of it it seems simple but there are these gotchas that catch me out.

I've shared a folder on the root of the C drive and given everyone read access, just as a test. In network sharing centre I've disabled password protected sharing. Whenever I browse to this server from a different machine (\machine) I get prompted for a login. When I try to browse directly to the folder (\machine\public) I also get prompted for a login. So despite the fact that password protected sharing is disabled it still isn't allowing anonymous access. Suggestions would be very much appreciated. Thanks

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

If you want to access the sharing on Windows Server 2008 computer from Windows XP and Windows 2000, you have to perform the following stesps:

  1. Change the settings in Network and Sharing Center

Please navigate to Control Panel >>> Network and Sharing Center, and ensure:

  1. Fire Sharing: On;

  2. Public folder sharing: Turn on sharing so anyone with network access can open files (or Turn on sharing so anyone with network access can open, change, and create files);

  3. Password protected sharing: Turn off password protected sharing

  4. Change the security settings in gpedit.msc

Please navigate to gpedit.msc >>> Computer Configuration >>> Security Settings >>> Security Options

Please change Network access: Sharing and security model for local account from “Classic-local users authenticate as themselves” to “Guest only-local users authenticate as Guest”

share|improve this answer
add comment

*Edit in gpedit.msc ( Window 2008 Enterprise Server )

gpedit.msc >>> Computer Configuration >>> Window Settings >>> Security Settings >>> Local

Policies >>> Security Options

then Search and Change in "Network access: Sharing and security model for local account" from

“Classic-local users authenticate as themselves” to “Guest only-local users authenticate as Guest”

share|improve this answer
add comment

GPEDIT is only available on the Pro & Ultimate versions of XP, Vista and Win/7. All HOME/* versions can not use this tool.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.