Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having problems getting attachments to work in a new Trac installation. I'm running Trac 0.11.1 on Ubuntu 9.04. I'm relatively new to Trac, so hopefully I'm just missing something obvious.

After uploading an attachment, I'm sent to an empty list of attachments. The ./attachments folder in the Trac project directory is also empty. In addition, attachment links don't show up correctly in Trac - they just display as text, no link.

I've checked, and the Apache user does have write permission to the ./attachments folder. Could there be some .ini setting I've overlooked?

I've turned on DEBUG logging in Trac, but nothing regarding attachment uploading appears in the logs.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

It seems the problem is related to version mismatches between Trac and Python in Ubuntu 9.04. The Trac package is 0.11.1 while the Python version mod_python uses is 2.6. This combination does not work: Trac Users post, Launchpad bug, Trac ticket.

Replacing the Ubuntu package repository's version of Trac with a custom install of Trac 0.11.4 as suggested by the Trac Users post makes the problem disappear, fortunately this is as easy as

sudo apt-get remove trac
sudo easy_install http://svn.edgewall.org/repos/trac/tags/trac-0.11.4
sudo /etc/init.d/apache2 restart
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.