Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Got an ESX server that's not booting after an array rebuild. Grub appears to be working properly, but I'm not getting any sort of response after the "boot" command. No error, no message, just a blinking cursor. I've rebuilt the initrd and run through the entire litany of esxcfg-boot commands. Any ideas? This is a production server, so any help is appreciated.

share|improve this question

4 Answers 4

Those sort of symptoms are usually caused by an functional boot loader, but it can't find the kernel. I'll assume you've also tried to boot the ESX Recovery GRUB option and found it didn't work.

Given you've just rebuilt the array, I'd be concerned that the rebuild was destructive and hosed your box.

If it was rebuilt to replace a dead disk, it's unlikely, but certainly not out of the realm of possibility for a RAID card with bugs or another form of hardware stupidity. If it was rebuilt to change RAID levels, it's almost certain the array is hosed.

Try creating an ESXi USB stick and boot from that; you may be able to convince it to read your storage to see what's left on disk.

If your VM's and VMFS datastores are intact, you could use ESXi to run them until your next maintenance window, or reinstall ESX to restore full functionality (being very careful to not destroy your datastores).

Good luck.

share|improve this answer

I would first try checking that you can manually see the device you want to boot from by getting to the grub menu and doing:

grub> root (hd [tab here])

and go through the other steps manually too. If you can't do it manually then you need to reinstall grub. It sounds like grub is hanging reading the initrd image rather than initrd failing.

Not a problem I have encountered however.

share|improve this answer
    
Yes, I've run each of the commands manually with the same result - no response after the boot command. The other commands all seem to work properly. I believe you're correct that initrd is not failing, but that grub is having a problem reading/executing the initrd image. –  jeffgilbert May 24 '09 at 22:19

Can you do a diagnostic on the array? maybe the array has not rebuilt correctly for some reason. Failing that it sounds like grub may need reconfiguring but without seeing your actual setup its difficult to know what to try.

share|improve this answer

You may want to ask in #linux, or #ubuntu, or #grub on freenode.

You can also press E in the grub screen to edit (or view what's executed). Try executing each step manually (Afair C is for command line). If it stops after the last one, it's Linux's fault, otherwise grub's.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.