Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a file server that was recently relocated in a transoceanic move. It isn't under warranty, as it was a custom-built in-house tower. When I hooked everything up and tried to boot it, the system does not respond at all -- power supply and motherboard fans don't spin up, no lights, no sounds. Nothing.

I tried swapping the motherboard (I have a couple of the exact same model) and power supplies with ones I believe to be good, but I don't have another tower case to check the on/off switch. I have a multimeter, but I've never used one before. How can I check to confirm or rule out the on/off switch? Are there any other items I might want to check?

Edit: Solved. Turns out it was a combination of a bad power switch and a bad power supply. The reset switch as power switch advice helped along with seeing the resistance change when the reset switch was pressed, but not when the power switch was pressed.

share|improve this question
add comment

5 Answers

up vote 4 down vote accepted

I have a multimeter, but I've never used one before. How can I check to confirm or rule out the on/off switch? Are there any other items I might want to check?

Turn your multimeter to the Ω/Ohm/Continuity tester. The Ω represents the amount of resistance in a circuit. A piece of wire (closed circuit) should have a resistance that is near 0 ohms. Air (open circuit) will have a very high resistance, most likely infinite from the perspective of your meter.

A power button on an ATX motherboard is a momentary switch. That means the circuit will only be closed when you press it.

Here is how I would test. Find two paper-clips and insert them into the motherboard connector for the power switch. Make sure the paper-clips to not touch each other. Touch one of the probes to one of paper-clips and the other probe to the other. While you have both probes contacting the paper-clips press the power button. If the button is good the reading on your multimeter should go from infinite ohms down to about zero.

alt text

BTW, if your case also has a reset button, you may be able to use that as a replacement for the power switch.. On an ATX case the reset button is just another momentary switch.

share|improve this answer
    
+1 and accepted -- this helped me narrow it down. See above for end result. –  romandas May 25 '09 at 15:11
add comment

You should be able to just manually short-circuit the power-on pins on the motherboard itself - the ones the on/off switch is connected to. Disconnect the switch and bridge the pins together, you could use the edge of a screw driver even - if you're a bit careful.

As you have switched motherboard and power supply at least once most other reasons I can think of would be moot (short-circuit by something fallen onto the motherboard, loose parts, loose cables in general and power supply issues). Pretty much the only thing needed to boot except those are a working and correctly seated cpu and some memory - it should at least give some sign of life even without a graphics card if it's not integrated. Try removing everything not needed, disconnecting drives and add-in cards - do the fans move at all, even if just very little?

share|improve this answer
    
Shorting it using a jumper didn't seem to cause any change on either motherboard -- I'm not sure this means anything though; perhaps this doesn't work for this type of board (FIC SD11)? –  romandas May 25 '09 at 0:10
add comment

This question was answered/solved already, but I wanted to mention an odd thing that happened to us once: a server wouldn't turn on after a power failure.

We'd push the power button but nothing would happen. We had an identical spare available, so we tried the power supply, but that didn't work. We put the hard drive from the dead box in the spare (and swapped power supplies back) and it was fine.

BUT, the original had a second NIC so we had to move that over as well and when we did, the new box wouldn't turn on. By this point, we were doing all the tests with the covers off, so we could see that when we pushed the power switch, fan would twitch and the nic power light would come on, but that's it. So we dug out a spare for the second nic and all was well.

share|improve this answer
add comment

Do you have access to the BIOS documentation? For example, do you know if it OUGHT to do beep codes if there is power but some other core peripheral (Say RAM, Video, or somesuch) is missing.

If it does do beep codes and you are not getting even that far and as said you have swapped power supplies and mother boards, something funny is up.

I imagine the key important piece of this device is the disk/disk array.

Do be careful with the power switch. There are still two kinds in existance. Those that need to just short the switch for a moment, and be released, and the more traditional switch, which lets all power run through it.

Obviously be much more careful with the latter kind! But with the former, a screwdriver is usually sufficient to short the jump over.

You should be able to hit a "Radio Shack" style store to pick up one of each type of switch. (If I recall Radio Shack the company in the US went out of business, but the company in Canada was sold, or something silly like that. I don't know who else is around these days that would carry these kinds of things).

share|improve this answer
2  
FYI, Radio Shack still exists in the States -- It's CompUSA that went out of business. –  romandas May 25 '09 at 0:13
    
Not sure how the disk or disk array is relevant, if the box never gets to POST. Could the CMOS battery affect things? –  romandas May 25 '09 at 0:14
    
Ok, I think Radio Shack the name is owned differently in Canada and the US that I might be mis-remembering. Regardless... As for the disk array, my point was that the data on the disk is the actual important thing. The hardware is either cheap or replaceable. The data, not so easily. –  geoffc May 25 '09 at 11:58
    
True; the drives seem fine -- but without a machine to use them in, they're little better than blocks of wood at the moment. –  romandas May 25 '09 at 13:53
1  
Yes, Radio Shack is now "The Source" in Canuckistan. The name was licensed to the Canadian company, but was revoked when the Canadian company was sold to a multinational competitor of someone that operates in both the U.S. and Canada, and owns the Radio Shack trademark in the U.S. –  CodeSlave May 25 '09 at 14:21
show 3 more comments

Have you considered a voltage/frequency issue? e.g., one was 220v/50Hz and the other is 110v/60Hz.

Maybe the power supply is smart enough to know it is not getting the power it is expecting.

share|improve this answer
    
The original power supply is supposed to be auto-sensing and is marked dual-voltage. The other has a manual switch on the back, and I switch it to 110v before using it. Though, I wonder if there might be a problem with the auto-sensing one along with the power switch.. –  romandas May 25 '09 at 14:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.