Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Connected a 3Com 2952-SFP Plus switch to a Cisco 3750 switch via fibre. There is a light on the 3Com end, but nothing at the Cisco end, and no traffic will flow. Have swapped SFP's, have swapped fibre cables, have used a different port on the Cisco, have even swapped the 3Com switch, but still no joy. When I connect a 3Com 2948 switch over fibre that works OK. Any ideas?

share|improve this question

3 Answers 3

The Cisco port has to be configured up to switch on the link-beat LED, by default most if not all Cisco ports are down. Try that and come back with a port config dump if you're still stuck.

share|improve this answer
    
The Cisco port is not down because as mentioned above I can connect with a 3Com 2948 perfectly fine. It's just the 3Com 2952's that won't connect. Port config on Cisco says not connected. Port config on 3Com says connected. I have also tested connecting the two 3Com 2952's to each other over fibre and that connection is OK. But neither of them will connect to the Cisco 3750. –  Noel Mar 5 '10 at 15:03
up vote 0 down vote accepted

Problem solved.
I came to the conclusion that the reason no link could be established between the 3Com and the Cisco switch was probably because they were unable to negotiate with each other to initially establish the connection type and speed. I therefore configured the Cisco port to NOT negotiate the speed. I left the 3Com with its default settings, which were “Auto”. The Cisco 3750 switch is a Gigabit switch with a fibre connector, and so with no negotiation is manually forced to run at 1Gb/s. Using CLI on the Cisco port interface the command is ‘speed nonegotiate’. As soon as I entered this command the line protocol was up and the link was established at 1Gb/s - the two switches are now working fine with each other.

share|improve this answer
    
I had this same issue with a 3750 series. It turned out to be line quality problems. I could disable autonegociation, and force the link, but it would have an error rate well over 10%. Replaced the line and everything was good. Might want to check the stats, make sure this isn't the same case. –  Chris S Apr 12 '10 at 13:17
    
Thanks for that Chris, but I’ve just checked the port stats and everything looks fine (the 3Com switch has actually been up and running for approximately 3 weeks now). Although I will check again in a week’s time when the switch will be more heavily utilised following the Easter Holiday break. –  Noel Apr 12 '10 at 13:37

Had the same problem with the 2952 connecting to a 3com 5500 SFP as our core. We had to set both speed and duplex settings manually on both ends for the link to come up on the 5500. Thanks for your help Noel... cheers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.