Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to export an NFS share from my Mac to a linux VMware, but I'm running into a problem with the export.

Things work fine when I export as:

/Users/garyrichardson/leap/nfs -rw 172.16.180.130

Macintosh-3:~ garyrichardson$ showmount -e
Exports list on localhost:
/Users/garyrichardson/leap/nfs      172.16.180.130

But if I try to use no_root_squash, the mount doesn't show up:

/Users/garyrichardson/leap/nfs -rw 172.16.180.130(no_root_squash)

Macintosh-3:~ garyrichardson$ showmount -e
Exports list on localhost:

Am I using the wrong syntax? Is no_root_squash not support under snow leopard?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Found my solution in man exports on the mac:

-maproot=user:group1:group2:... The colon separated list is used to specify the precise credential to be used for remote access by root. The elements of the list may be either names or numbers. Note that ``user:'' should be used to distinguish a credential containing no groups from a complete credential for that user.

which leads to:

In the absence of -maproot and -mapall options, remote accesses by root will result in using a credential of -2:-2. All other users will be mapped to their remote credential. If a -maproot option is given, remote access by root will be mapped to that credential instead of -2:-2. If a -mapall option is given, all users (including root) will be mapped to that credential in place of their own.

So I used:

/Users/garyrichardson/leap/nfs -rw -maproot=501:501 172.16.180.130
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.