Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
  • I have CA on the same server (windows 2003) as my second domain server.
  • I created certificate for my user
  • In Administrative Tools->Active Directory Users and Computers->(My user)->Account tab->Account Options I've checked "Smart card is required for interactive logon" check box

From that moment Windows required me to login using my smart card.

After few days I wanted to disable it.
So again In Administrative Tools->Active Directory Users and Computers->(My user)->Account tab->Account Options I've disabled "Smart card is required for interactive logon" check box

dear windows - it's disabled

But windows completly ignores this setting. Even this domain server on which I disabled it still requires me to use smart card.

What else should I do to disable smart card logon ?

share|improve this question
up vote 2 down vote accepted

Aha, found it.

MSKB article 892424 has one important sentence:

On a Windows Server 2003-based domain controller, if the "Smart card is required for interactive logon" policy setting is enabled, the domain controller generates a random password for the user.

So I was unable to logon after disabling the check box because my password was set to some random value instead of my old password.

After resetting it, both password logon and smart card logon works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.