Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a folder mounted on an Ubuntu 8.10 sever through cifs that I simply cannot change the permissions on once mounted.

Here is a breakdown of what's going on:

  • All files within the mounted folder automatically have their permissions set to -rwxrwSrwx regardless of whether the file is create on the windows server or on the linux machine.
  • I have the same directory mounted on two other linux servers (both running 9.10 instead of 8.10) with no problems at all. They all are using the same fstab options and the same credentials.

    //server/folder /media/backups cifs credentials=/etc/samba/.arcadia_cred,noexec,noserverino 0 0

  • I've I run a chmod command a million different ways, all of which report successfully changing the permissions. However it doesn't.

  • The issue began after I updated from 8.04 to 8.10

Any idea why this may be happening on one machine? Since it started after an upgrade I'm not sure what is the bes thing to do.

Any help you could give would great! None of my automated backup scripts are working because of this!

share|improve this question

1 Answer 1

up vote 4 down vote accepted

What OS is the server? Does it support CIFS Unix extensions? If not then nothing you do with chmod matters. You can set the user owner, file and directory permissions by setting options within your mount.

http://linux.die.net/man/8/mount.cifs

uid=arg
sets the uid that will own all files on the mounted filesystem. It may be specified as either a username or a numeric uid. This parameter is ignored when the target server supports the CIFS Unix extensions.

gid=arg
sets the gid that will own all files on the mounted filesystem. It may be specified as either a groupname or a numeric gid. This parameter is ignored when the target server supports the CIFS Unix extensions.

file_mode=arg If the server does not support the CIFS Unix extensions this overrides the default file mode.

dir_mode=arg If the server does not support the CIFS Unix extensions this overrides the default mode for directories.

share|improve this answer
    
Wow. This is just embarrassing! I had assumed that since I had the same file server mounted on a different linux machine and it was worked it was something strange. I never tried to chmod on the other server though and when I did, it definitely didn't do anything. Thank you for the help! –  mattmcmanus Mar 22 '10 at 13:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.