Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Switch: Netgear 7352PS Created a VLAN (id = 10), and assigned ports 13 through 24 to that vlan. Also configured PVID as 10 for all these ports.

Machine A: 172.31.192.111/24 Machine B: 172.31.192.110/24

I connected both A and B to ports 13 and 21 respectively. The ping between A and B is not working.

Am I missing something obvious here? Or better put, whats the best way to troubleshoot this?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Do you see the mac address with the corresponding IP of the other machine on the current machines arp table? arp -a in Linux.

share|improve this answer
    
Right now, the ping from A to B is working. "arp -a" on A shows an entry for B. B to A is not working. Changed cables, and no arp entries. B is also connected to the switch console via serial. –  RainDoctor Mar 3 '10 at 22:25
    
Oh, ya, sounds like a firewall on B to me. A firewall that blocks ICMP would typically allow ICMP replies from pings, but not pings that it did not initiate. –  Kyle Brandt Mar 3 '10 at 22:31
    
Yeah, you are correct. XP firewall is the culprit. Thanks guys! –  RainDoctor Mar 3 '10 at 23:00

Check to see if there is there a host based firewall on the PCs that is blocking ICMP. Drop a packet sniffer on the receiving machine and see if the ping is even getting to the target.

share|improve this answer

Sounds like it's an issue on the hosts (check network configuration, firewalls, etc.).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.