Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are using LSI 1068E raid chipset with SAS drives.

We had added new drives to the system, and tried to create new raid volume with the lsiutil, unfortunately the creation failed. The problem is that now we do not have the new raid volume and disks 'disappeared' and are not available as targets for raid.

Lsiutil option 8 (scan for devices) does not display these disks at all.

lsiutil option 16 (display attached devices) does list them as targets.

lsiutil option 21+30 (create raid) does not list these disks.

Just after insrting them to enclosure these disks appeared in the system, as expected. During the raid creation kernel logged:

Mar  4 08:40:02 kilo kernel: [57555.687946] mptbase: ioc0: RAID STATUS CHANGE for PhysDisk 2 id=0
Mar  4 08:40:02 kilo kernel: [57555.687978] mptbase: ioc0:   PhysDisk has been created
Mar  4 08:40:02 kilo kernel: [57555.695438] scsi target0:0:2: mptsas: ioc0: RAID Hidding: fw_channel=0, fw_id=0, physdsk 2, sas_addr 0x5000c50008ebe5fd

for both of them, again as expected. Unfortunately they did not appear back even though the volume was not created.

The same situation is in the controller's bios after a reboot.

Taking the disks out and inserting in different slots did not help, either.

Has someone seen a similar problem? And knows how to 'get back' our disks?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Still doesn't know what really happened, and probably will never know.

We connected those disks to other controller, not with 1068E chipset, it did see them correctly, we created and removed an array and now our 1068E sees them correctly. We have not tried to create an array with it and decided to just use Linux's software raid.

It seems to some deficiency or just a bug in LSI 1068E.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.