Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a problem after upgrading from Python 2.5 to 2.6

I'm using Gentoo and running a Django app with Apache 2 and mod_python. After the upgrade I started getting a segfault when I try to access the site, Apache starts fine and can serve static pages.

I've tried moving the site to mod_wsgi and still get the segfault. I've tried reinstalling Apache, Apr, mod_python, mod_wsgi. I've tried revdep-rebuild, python-updater. I've removed Python 2.5 from the system. The site works when I run it from Django's development server.

I'm lost, I just don't know how to fix this. Any help would be appreciated. Thanks in advance.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Start by reading:

http://code.google.com/p/modwsgi/wiki/InstallationIssues http://code.google.com/p/modwsgi/wiki/ApplicationIssues http://code.google.com/p/modwsgi/wiki/DebuggingTechniques http://code.google.com/p/modwsgi/wiki/WhereToGetHelp

Various reasons for crashes are documented and also pointers to how to configure Apache/mod_wsgi to get more logging etc about what is going on.

share|improve this answer

Ok, finally I've found the problem.

It was pysco, I forgot I had it installed and was imported by my site. I removed it and everything works now.

I've used gdb to find out. Thanks for your help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.