Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to svn co to a directory on Ubuntu, shared via samba, to OS X, but I get the following error (in OS X).

svn: In directory 'site/product/tests'
svn: Can't open file 'site/product/tests/.svn/tmp/text-base/._base.py.svn-base': No such file or directory

My smb.conf file includes the following changes:

unix extensions = no
browseable = yes
public = yes
writable = yes
delete readonly =  yes
create mask = 0775
directory mask = 0775
valid users = %S
read only = no

The checkout works fine locally (on the Ubuntu machine).

What am I missing?

More detail:

Later inspection showed that the svn error couldn't find the file with 3, then 2 underscores:

.___init__.py.svn-base

Whereas listing the directory in OS X showed 2, then 2 underscores:

__init__.py.svn-base

And listing the same directory in a successful checkout on Ubuntu shows nothing (because it's a temporary directory?)

I've tried the mangled = no setting in share settings, to no effect.

share|improve this question
add comment

1 Answer

So, to clarify, you get the error message when running svn co on OSX under the mounted share?

Have you examined the file and directory referred to by the error message? Offhand I'd guess your Samba configuration is mangling that name, which is why it doesn't appear on the OSX mount. If this is the case, and the file *._base.py.svn-base* exists in that directory, you won't see it from the OSX side but you will from the Ubuntu side. Instead you might see a file with *"_"* (three underscores) as its extension.

Samba mangles names by default, so you turn name mangling off by setting this in your smb.conf (I believe it's a global option, but it might be per-share):

mangled names = no

Once you've added that to the configuration, restart Samba, remount the share on OSX, and check the directory again. If this is the correct diagnosis you should now see the file.

share|improve this answer
    
Your diagnosis seems close, but the fix has no effect.... see extra detail in OP. (Your clarification is correct) –  Jon Hadley Mar 5 '10 at 12:54
    
Name mangling is on by default and the setting is per share: oreilly.com/catalog/samba/chapter/book/ch05_04.html –  Jon Hadley Mar 5 '10 at 12:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.