Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm configuring Feature Delegation on IIS 7.0 to allow some customers to use IIS Manager for Remote Administration to configure their sites.

There are some features where I want to remove delegation and make the feature read-only but allow the user to see the settings. This works fine.

There are other features I want to configure to have no delegation at all but also hide them from the remote IIS manager when they connect to the site.

Is there a way to do this in IIS 7.0/Windows 2008?

Update:

In addition to Scott's answer, if you set a feature to "Not Delegated", you need to reconnect to the site using Remote IIS Manager to see the change. Doing a right-click refresh doesn't do this.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You can manage this from administration.config in %windir%\system32\inetsrv\config.

Just pull the items out of the <modules> section, or you can create a custom section for different users using <location> tags and customize them for each.

Note that people can still obtain any setting from code, so you won't be completely hiding anything, but there are still valid reasons to customize what features are available for your users.

share|improve this answer
    
Hi Scott, thanks for the response. Actually....I just discovered that if I disconnect and reconnect to a site using Remote IIS Manager the feature is indeed hidden from view. I thought that doing a right-click refresh on the site in Remote IIS Manager would refresh the Feature Pane accordingly, but not so. –  Kev Mar 6 '10 at 14:19
    
Hi Kev. Great, that makes sense and it sounds like your delegation changes at the server level took care of it. You're right, if it's a UI change, then IIS has to be restarted. If it's a setting change (i.e. updating a setting directly from applicationHost.config) then a refresh will work. –  Scott Forsyth - MVP Mar 8 '10 at 13:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.