Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This might sound amazingly stupid but I have a DD-WRT (micro) router that I placed in my network to act as a switch and as a WAP while relying on my cable modem to be the DHCP server. In my attempts to get the configuration right I put the router into DHCP forwarder which then made everything work correctly. The problem is now I can't seem to connect to the router in any fashion to add mac addresses to the WAP access list.

Is there something I'm missing or do I need to try a hard reset on it and reconfigure everything?

share|improve this question

closed as off-topic by Falcon Momot, Michael Hampton Aug 4 '13 at 5:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is a site dedicated to professionals; novice questions are off-topic. Please see the Help Center for more information on topicality. The best advice we can give you is to hire a professional to help you out." – Falcon Momot, Michael Hampton
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Any luck? Anything here solve your issue? –  gWaldo Sep 3 '10 at 12:14

4 Answers 4

up vote 2 down vote accepted

You may have to do a hard reset on it. In the main setup screen, you can set the router's static LAN IP address, which is how you will access it once you set it up as a switch.

Aside from that, I would recommend that instead of using it as a dhcp forwarder, you leave it on dhcp server, and disable the dhcp server. Then set the WAN type to Disabled, then check the box to "Assign WAN Port to Switch"

This will put it in a truly 'switch' mode. Using it as a DHCP forwarder is not fully transparent.

Here is a screencap of my settingsalt text

share|improve this answer
    
This is close, I used the information on this link dd-wrt.com/wiki/index.php/Wireless_Access_Point but i did have to do a hard reset. –  Chris Marisic Nov 12 '10 at 19:52

If you have a DHCP server(service) running on your cable modem (and by cable modem I assume a modem/router), then do the following:

  1. Disable DHCP on your router
  2. Assign your router a static ip on the same subnet (usually 192.168.1.x)
    • Use something outside the normal assignment range of your cable modem
  3. Set your wireless like always
share|improve this answer

Your problem might be due to either:

  1. You are trying to access http://dd-wrt and that won't work because your cable-modem dns server does not know the IP address of dd-wrt. To correct this, connect to the dd-wrt directly using its IP address (such as 192.168.0.1 or whatever it was set to).
  2. You are trying to access the dd-wrt router using IP address but it exists in a different subnet because the cable modem had given you a different IP address from that in the router. To correct this, you will need to use an ethernet cable to connect to the router and set your ip address on the ethernet interface manually to one within the router's subnet.

Of course, the easiest way to fix this problem is to hard-reset your router, as mentioned by others. That will restore the router to its default configuration, as a dhcp server.

share|improve this answer

I have a similar setup at home, (but I won't be accessing it from here to verify details), but I think that you want to set your 'WAP' as a Wireless Bridge (or Client Bridge in their terms)

http://dd-wrt.com/wiki/index.php/Client_Bridged

I have my main wifi router in the basement with a couple of servers attached by ethernet cables. Wifi of course works everywhere. I have an office upstairs, and it's not practical to run ethernet down to the basement. I have some machines that I can't add wifi to, so I wire them to a second router (the dd-wrt'd machine in client bridge mode), which is connects to the main router over wifi (on the same SSID, so they're on the same LAN). The client bridge does not give out DHCP; it forwards the requests to the main router.

Sound like your situation?

If this is what you are trying to do, and you are continuing to have problems, send me a message and I'll confirm on my home rig this evening.

share|improve this answer
    
This sounds like exactly what he wants. dd-wrt as a switch cannot do WAP and vice versa to my knowledge. If you want to extend your your network via wireless to provide additional lan ports use Client bridge as linked. –  Chris Aug 31 '10 at 12:46
    
@Chris I can without a doubt say that DD-WRT can function as both a switch AND a wap. I have my uplink cable in port 1 (not uplink port), my pc in port 2, and PS3 in port 3 and my G1 on Wifi. –  Chris Marisic Aug 31 '10 at 15:34
    
Well, what I meant to say was a dedicated switch. What you are doing I believe is considered using it as a router where you have 4 physical lan ports and wifi available. This is different from a simple dedicated switch from what I know but feel free to comment if I am mistaken. –  Chris Aug 31 '10 at 15:56
    
dd-wrt.com/wiki/index.php/Wireless_Access_Point#LAN_Uplink turning the Router into a WAP will make it behave as a switch, there's also the ability (for some routers) to turn the WAN uplink port into a regular switch port also. –  Chris Marisic Nov 12 '10 at 19:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.