Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Search Crawling is error out on my MOSS 2007 installation.

I get the following error for all the web apps I have following error in Crawl logs.

http://mysites.devserver URL could not be resolved. The host may be unavailable, or the proxy settings are not configured correctly on the index server.

The Application Event log also has the following corresponding error The start address http://mysites.devserver cannot be crawled.

Context: Application 'SSPMain', Catalog 'Portal_Content'

Details: The URL of the item could not be resolved. The repository might be unavailable, or the crawler proxy settings are not configured. To configure the crawler proxy settings, use the Proxy and Timeout page in search administration. (0x80041221)

I'm using Windows 2008 server. I tried accessing the site using the above mentioned url and its available. I did the registry setting for loop back issue found here still not luck. Any Ideas?

share|improve this question
Are you able to crawl the IP address? – Nat Mar 12 '10 at 6:10
have you extended your web application and or configured alternate access mappings? if so there is extra IIS stuff required. I don't know the fix but I know we ran into that and my engineer had to do some IIS changes to correct it. also maybe try this on – Jordan W. Feb 17 '12 at 16:23

Try some basic network tests from the server doing the crawl. You need to try the following:

  • nslookup the fqdn and the hostname
  • ping the ip address returned from above
  • browse to the URL

This is just in case it is something simple - if you have a network issue with the crawl server then you won't get any further.

Check for any errors under Central Admin > Application Management > Check Services Enabled on this Farm - that should highlight any issues with SSPs etc.

Also check your server application logs, and Sharepoint ULS logs (Codeplex has a great Sharepoint Solution for this - LogViewer)

Also - can you specify a little more about your environment:

  • how many servers on farm? roles?
  • any network load balancing going on?
share|improve this answer

Check that the farm level search settings aren't set to use a proxy server, or if you need to use one, make sure the proxy server is correct.

share|improve this answer
No, I checked it, its set to not use proxy server. – Satish Mar 8 '10 at 14:32

I had the exact same problem, you need to increase the connection timeout in the farm search administration screen, I change this on my VM from 60 seconds to 120 seconds and im now crawling content successfully.

share|improve this answer

This article might help to troubleshoot your issue..

Thanks, Kalashnikov

if it helps, Please dont forget to mark it as an answer. Thank you.

share|improve this answer

Try telnet to the URL you are trying to crawl in your search service application. If it does not work. That is the issue.

IF you are able to telnet you will be able to crawl it.

Solution: Work with DNS team to make sure you are able to access the URL from search service

OR put host entry in the host file of search server and point to WFE and in the WFE go to firewall and add the PORT for web application to allow inbound communication.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.