Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a test server on a Windows 7 Machine with apache 2.2 installed. On it PHP 5.2.11 was workig fine (as a module). But when I try to install 5.2.13 (or greater). It doesn't start.

Nothing beside the PHP version is different. I unzip the files and add the lines.

LoadModule php5_module "c:/PHP/php5apache2_2.dll"
AddType application/x-httpd-php .php
PHPIniDir "c:/PHP"

But that LoadModule directive doesn't let apache start. When I comment that line apache starts. When I replace the files with those in 5.2.11 package Everything works fine again.

Does anyone have any ideas?

share|improve this question
    
i dont know why this happened but with this post you save me after 4 hour losing my head over why this didnt work! i just used the 5.2.11 and everything works well now!!! thanks a lot really! –  user57362 Oct 16 '10 at 23:57

1 Answer 1

  • Try to check the Windows event log and any other configured log files for Apache and PHP.
  • Try 5.2.12 to see what that gives. Why is 5.2.13 needed? Why not go to 5.3.*?
  • Try another version of Apache.
  • Try reinstalling both Apache and PHP.
  • Try to use IIS 7 instead of Apache as a last resort.
  • Try an all-in-one package like XAMPP that will do the hard stuff for you.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.