Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an application running in local google app engine and I am trying to expose it over the internet for some testing. I have successfully set up port forwarding in my router. Used this tool (https://www.dyndns.com/support/tools/openport.html) and the mu torrent open port checker to test it and both say the port is open and is accepting connections. When I type in my external ip I am taken to the router login page but when I try to access my app running on port 8080 (http:x.x.x.x:8080) I get an "unable to connect error". Any pointers on how to diagnose this issue?

My windows firewall is off and I am able to access the app from other boxes in the intranet using intranet ip.

share|improve this question
add comment

3 Answers

Sounds like you have only tried using the external ip address from "inside" your local NAT network? Generally these kind of port forwarding only works from the "outside". That is, you will have to test it from a computer outside your router.

share|improve this answer
    
You are right. It does work from outside. How do make it work from inside also? –  abhirama Mar 6 '10 at 10:36
    
From the inside you go directly to the internal address, to which the external address is being port forwarded. Assuming you have a normal home router I doubt it's capable handling it for you in any other way. What you can do is get the "correct" domain name from the inside, either by modifying your local host file, or setting up an internal DNS lookup server. –  andol Mar 6 '10 at 12:13
    
I cannot use the local etc host trick. I am trying to develop a facebook application with google app engine and I need this set up for my testing. I am running google app engine locally and using dynamic dns to point it to my local app engine server and pointing facebook app address to the address given to me by the dynamic dns server. –  abhirama Mar 6 '10 at 12:26
add comment

By default the development server only binds to 127.0.0.1 and will only answer requests directed to that address. You can change the default behavior so it binds to 0.0.0.0 and listens on all addresses by passing in the --address= flag when you start up the server. This is documented here:

http://code.google.com/appengine/docs/java/tools/devserver.html

For instance, if you are using Eclipse, you would add "--address=0.0.0.0" to your program arguments under the Run Configuration/Debug Configuration menu.

share|improve this answer
add comment

If it works from outside, but not in, it would seem that your router doesn't forward the port if the traffic originates inside your network.

share|improve this answer
    
Is there a way to make this work? –  abhirama Mar 6 '10 at 11:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.