Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Running the install.sh script as-is from Virtualmin (GPL version), I get a dovecot error after about 5.5mins of installation.

I have tried this on several versions of the server - same error whether or not I run apt-get update +/- apt-get upgrade .... and whether or not I have the FQDN set.

Here's the end of the installation: http://screencast.com/t/ZDkxMmY1NDQ

Any hints/suggestions, etc. would be much appreciated...

Thanks, Rob


Here are the last 100 Lines of the virtualmin-install.log. Apologies for posting the video, I thought it would be the best way to share the info. Thanks for letting me know otherwise.

Configuration file `/etc/quotatab', does not exist on system. Installing new config file as you request.

Configuration file `/etc/warnquota.conf', does not exist on system. Installing new config file as you request.

Configuration file `/etc/cron.daily/quota', does not exist on system. Installing new config file as you request.

Configuration file `/etc/quotagrpadmins', does not exist on system. Installing new config file as you request. Setting up rdoc1.8 (1.8.7.72-3lenny1) ... Setting up rdoc (4.2) ... Setting up re2c (0.13.5-1) ... Setting up ri1.8 (1.8.7.72-3lenny1) ... Setting up ri (4.2) ... Setting up sasl2-bin (2.1.22.dfsg1-23+lenny1) ...

Configuration file `/etc/default/saslauthd', does not exist on system. Installing new config file as you request.

Configuration file `/etc/init.d/saslauthd', does not exist on system. Installing new config file as you request. To enable saslauthd, edit /etc/default/saslauthd and set START=yes (warning). Setting up scponly (4.6-1.3) ...

Configuration file `/etc/scponly/debuglevel', does not exist on system. Installing new config file as you request. Setting up sgml-base (1.26) ... Setting up spamassassin (3.2.5-2+lenny2) ...

Configuration file `/etc/default/spamassassin', does not exist on system. Installing new config file as you request.

Configuration file `/etc/spamassassin/local.cf', does not exist on system. Installing new config file as you request.

Configuration file `/etc/spamassassin/v320.pre', does not exist on system. Installing new config file as you request.

Configuration file `/etc/spamassassin/v310.pre', does not exist on system. Installing new config file as you request.

Configuration file `/etc/spamassassin/v312.pre', does not exist on system. Installing new config file as you request.

Configuration file `/etc/spamassassin/init.pre', does not exist on system. Installing new config file as you request.

Configuration file `/etc/spamassassin/65_debian.cf', does not exist on system. Installing new config file as you request.

Configuration file `/etc/cron.daily/spamassassin', does not exist on system. Installing new config file as you request.

Configuration file `/etc/init.d/spamassassin', does not exist on system. Installing new config file as you request. SpamAssassin Mail Filter Daemon: disabled, see /etc/default/spamassassin Setting up spamc (3.2.5-2+lenny2) ... Setting up subversion (1.5.1dfsg1-4) ...

Configuration file `/etc/emacs/site-start.d/50psvn.el', does not exist on system. Installing new config file as you request.

Configuration file `/etc/subversion/config', does not exist on system. Installing new config file as you request.

Configuration file `/etc/subversion/servers', does not exist on system. Installing new config file as you request.

Configuration file `/etc/bash_completion.d/subversion', does not exist on system. Installing new config file as you request. Setting up apache2-suexec-custom (2.2.9-10+lenny6) ...

Configuration file `/etc/apache2/suexec/www-data', does not exist on system. Installing new config file as you request. dpkg: dependency problems prevent configuration of virtualmin-base: virtualmin-base depends on dovecot-common; however: Package dovecot-common is not configured yet. virtualmin-base depends on dovecot-imapd; however: Package dovecot-imapd is not configured yet. virtualmin-base depends on dovecot-pop3d; however: Package dovecot-pop3d is not configured yet. dpkg: error processing virtualmin-base (--configure): dependency problems - leaving unconfigured Setting up xml-core (0.12) ... Setting up mailx (1:20071201-3) ... Errors were encountered while processing: dovecot-common dovecot-imapd dovecot-pop3d virtualmin-base FATAL - 2010-03-06 18:14:32 - Fatal Error Occurred: Installation failed: 0 FATAL - 2010-03-06 18:14:32 - Cannot continue installation. FATAL - 2010-03-06 18:14:32 - Attempting to remove virtualmin repository configuration, so the installation can be FATAL - 2010-03-06 18:14:32 - re-attempted after any problems have been resolved. FATAL - 2010-03-06 18:14:33 - Removing temporary directory and files. FATAL - 2010-03-06 18:14:33 - If you are unsure of what went wrong, you may wish to review the log FATAL - 2010-03-06 18:14:33 - in /root/virtualmin-install.log

share|improve this question
1  
a screencast of plain text is rather pointless.. Next time copy and paste the actual log into your question as a code block.. The screencast refers to the "last 15 lines" of virtualmin-install.log which is not enough to see what went wrong. posting that file would be most helpful. –  Justin Mar 6 '10 at 21:07

1 Answer 1

The video isn't working for me.

Paste in the last few lines before the bit about "displaying the last 15 lines of the log file", as sometimes that's actually where the problem shows up. The log, unfortunately, can't capture everything on all systems (apt-get doesn't like being run from scripts, and it makes capturing everything, while still providing feedback to the user about what's happening, really difficult, if not impossible).

Check the last 100 lines or so of virtualmin-install.log for clues.

What Dovecot error, specifically, are you getting?

(I wrote the install script. I can usually spot the problem, if I see the actual errors. And, I can also probably fix the problem in future releases, if I understand why it is happening. My last Debian install two days ago worked great, so this is not a known issue.)

Edit:

OK, so it looks like dovecot isn't installing correctly for some reason. Maybe conflicts with other packages already installed on the system. apt-get is pretty hateful about changing packages to satisfy dependencies.

So, try running:

apt-get install dovecot-common dovecot-imapd dovecot-pop3d

And see what happens. If it works, then you could try the Virtualm install again.

share|improve this answer
    
yeah, I'm sure it is a trivial problem to fix, but it is impossible to say what is wrong without seeing the first half of the error from dpkg. –  Justin Mar 8 '10 at 1:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.