Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have enabled Linux active backup mode bonding. Each interface is a gigabit interface, but the bond interface seems to end up at 100 Megabit:

bonding: bond0: Warning: failed to get speed and duplex from eth1, assumed to be 100Mb/sec and Full.
...
bnx2: eth0 NIC Link is Up, 1000 Mbps full duplex, receive & transmit flow control ON  
... 
bonding: bond0: backup interface eth1 is now up

ethtool apparently can't provide info on bond:

sudo ethtool bond0
Settings for bond0:
No data available

So does this mean I am operating at 100 or 1000 Megabit (My guess is 1000)? If it is only 100, what options in the ifcfg scripts or the modprobe bonding options do I need to sett to make it 1000?

share|improve this question
1  
I don't think that ethtool would be able to provide information about a virtual interface. You would have to do it on each component interface. –  Kevin M Mar 8 '10 at 16:33

2 Answers 2

up vote 2 down vote accepted

Looks like I am at 1000, someone on the developers mailing list was kind enough to explain it:

...
Later, when the slave device asserts carrier up, bonding will
receive a notifiation, and will update the speed and duplex information
(quietly).
share|improve this answer

Are one of your connections connected to a 100MB switch?

share|improve this answer
    
All gigabit, each individual interface (bnx) negotiates at 1000 –  Kyle Brandt Mar 8 '10 at 19:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.