Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

when i do "route print" on my machine, it shows my default gateway as 10.225.150.1

but when i do tracert www.google.com, the first machine it reaches is 10.225.150.2. The route command does not show any entry for 10.225.150.2.

So, why tracert is showing 10.225.150.2?

my maching is on Windows XP.

share|improve this question
1  
Can you send the output of ipconfig /all tracert www.google.com route print J –  James Mar 7 '10 at 20:49

2 Answers 2

If the IP of the gateway has recently changed, you may have stale arp cache. Validate that you do not have the 150.2 IP associated with the hardware address of your gateway. Your arp cache can be inspected with:

arp -a

or cleared with:

arp -d *

Is the condition you describe in your questions currently causing a problem for you or just a curiosity? If a problem, can you provide specifics for what you're trying to accomplish?

share|improve this answer

If your gateway is Multihomed it might have several IPs assigned to it but traceroute will only show one. The one shown doesn't have to be the one you're using as your default GW. You would find this kind of setup on corporate networks mostly, not so much with home routers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.