Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i try to speed up boot time of my linux server box which uses removable HDD rack's the current boot time is around 2 min's but if i connect the hdd's directly to the mainboard its about 2 sec's the problem is that ahci's kernel implementation causes a timeout of around 30 seconds for each disk during boot which originates from the hdd-rack after the timeout the kernel prints that the disk is limited with speed to 1.5gbps and udma/133 is used

so the question i have is: how can i set this in grub as a boot option so the kernel doesnt have to wait for a timeout and just hardcoded limits the speed of the disks? i read about a few options like pci=nomsi or such, which dont work

thats why im asking for limiting precisely the disks during boot

thx

share|improve this question

migrated from superuser.com Mar 7 '10 at 19:24

This question came from our site for computer enthusiasts and power users.

    
this question is fine for here, but may get better responses on Server Fault. please don't crosspost it there; it will be migrated automatically if necessary. if it is migrated, you need to register on Server Fault and associate your accounts to regain ownership of the post. –  quack quixote Mar 7 '10 at 18:55
    
Is the ACHI timeout a BIOS or Linux kernel issue? –  mctylr Mar 9 '10 at 2:03

1 Answer 1

Add this

libata.force=1.5

to your boot options and it will force libata to 1.5Gbit. You can also force DMA modes etc, check out kernel-parameters.txt in your kernel documentation directory (or online say here)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.