Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been struggling for a while with a problem with ActiveSync, it is giving 401.2 errors when trying to access the mailboxes. Oddly enough, clients can get to the calendars just fine. I've tried from an Android device as well as the Exchange remote connectivity troubleshooter, same error both times. Here is the configuration:

  • Connectivity through ISA 2006
  • Exchange 2007 on Windows 2008
  • Basic authentication is on
  • ISA is passing through all authentication directly to the Exchange server
  • The user IS allowed to get to ActiveSync in their Exchange mailbox settings

I have tried the following, without success:

  • Making SSL not required
  • Enabling Windows Integrated and Digest authentication

Here is an example of the errors in the IIS log:

OPTIONS /Microsoft-Server-ActiveSync/default.eas - 443 - 192.168.32.18 TestActiveSyncConnectivity 401 2 5 0

Here is what I am seeing in my trace log:

ModuleName IIS Web Core 
Notification 2 
HttpStatus 401 
HttpReason Unauthorized 
HttpSubStatus 2 
ErrorCode 2147942405 
ConfigExceptionInfo  
Notification AUTHENTICATE_REQUEST 
ErrorCode Access is denied. (0x80070005) 

I'm 100% stumped. Any clues?

share|improve this question
add comment

1 Answer 1

I solved it! Thanks for all the help guys, you put me on the right track here Charlie! When I changed ISA to be set to "Basic" authentication instead of "No delegation, but client may authenticate directly" the problem was solved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.