Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

If I have a router that has several LANs on it, and each of these LAN is attached to a second router, do I need to use different HSRP groups for each LAN?

With this set up, each virtual gateway will be on a Layer 2 segment. And within a router, no interface will have multiple gateways.

So, For example:

Router 1:

F0/0:
ip address 192.168.1.2 255.255.255.0
standby ip 192.168.1.1
F2/0:
ip address 192.168.2.2 255.255.255.0
standby ip 192.168.2.1

Router 2:

F0/0:
ip address 192.168.1.3 255.255.255.0
standby ip 192.168.1.1
F2/0:
ip address 192.168.2.3 255.255.255.0
standby ip 192.168.2.1

Will this work, or do I need standby 1 ip 192.168.2.1 on the F2/0 interfaces? (When no group is specified, the default group is 0.) Since according to the RFC, the group number of the packet is in the HSRP multicast packets, my guess is that I don't need different groups, and that multiple groups are only needed when they are all on the same Layer 2 segment. However, I haven't been able to find this setup....

share|improve this question

1 Answer 1

up vote 4 down vote accepted

If these LANs are all on separate L2 segments, you can safely use the same HSRP group number on all of them. I have seen this used in production with no issues; 100+ VLANs on a 6500 router pair all using HSRP group 1. Like you, I can't find any documentation blessing this right now.

One example I have seen where multiple HSRP groups used were used on the same interface was for combining subnets. For example, given the following two subnets:

interface Vlan1
 ip address 192.168.1.2 255.255.255.128
 standby 1 ip 192.168.1.1
!
interface Vlan2
 ip address 192.168.1.130 255.255.255.128
 standby 1 ip 192.168.1.129
!

If you wanted to combine them into one subnet (192.168.1.0/24), but maintain both existing HSRP addresses while hosts were reconfigured, the following configuration:

interface Vlan1
 ip address 192.168.1.2 255.255.255.0
 standby 1 ip 192.168.1.1
 standby 2 ip 192.168.1.129
!

Would allow you to do so.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.