Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently finished installing Squid on a VPS I have in the US and its working fine locally (I verified by setting http_proxy variable and using lynx).

I want to access this proxy over the internet (as an anonymizer) so that I can see how some ads show up for US traffic on my website. I have setup authentication so abuse is not a problem. However, I am not able to access the proxy over the internet. I have set the following rule in squid.conf

http_access allow all

Is this not possible to do what I want or I am missing something? The port 3128 is open in the firewall so that is not an issue. Squid is running on 0.0.0.0

Thanks Prateek

share|improve this question

migrated from stackoverflow.com Mar 8 '10 at 23:45

This question came from our site for professional and enthusiast programmers.

    
Have you confirmed that port 3128 is not blocked by your ISP or by a local firewall? –  mctylr Mar 9 '10 at 2:02

1 Answer 1

you have to check squid logs (usually at /var/log/squid/access.log i am sure that access is denied form squid. You should enable that.

I recommend to tunnel squid via ssh to get secure access, for checking ads from US thats the best way to do it (forcing an squid)

share|improve this answer
    
Indeed - tunneling over SSH extremely sensible precaution. +1 :) –  Tom Newton Apr 9 '10 at 14:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.