Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I try to start apache or run the command,

httpd -M

each fail and print the following error:

httpd: Syntax error on line 137 of /etc/httpd/conf/httpd.conf: Syntax error on line 2 of /etc/httpd/conf.d/proxy_ajp.conf: Cannot load /etc/httpd/modules/mod_proxy_ajp.so into server: /etc/httpd/modules/mod_proxy_ajp.so: undefined symbol: proxy_module

Any ideas on how to fix this? Thanks.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Make sure there is there a line to load proxy_module in httpd.conf:

LoadModule proxy_module modules/mod_proxy.so

And make sure that that file exist and has reasonable permissions.

share|improve this answer
    
thanks, the ordering of my LoadModule statements were incorrect. It's working now. –  Silmaril89 Mar 12 '10 at 0:20

Aha! why not run "httpd2 or httpd -t" or if you are in RHEL pls run apachectl configtest

to get it pinpointed...means why this cause error.Make sure the module is loaded properly in the main config file or the module specified file.

last but not the least..pls try activate the module by a2enmod modulename ...yes that "a2enmod"

is the command with the argument of the specific module.

BTW it all depends what sort of distribution you are running... but basic underlying fact is to enable the module proper way.

Cheers Bhaskar

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.