Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is there a way to automatically enable remote desktop connections to my workstations? I've tried enabling the following:

Windows Components / Remote Desktop Service / Remote Desktop Session Host / Connections - Allow users to connect remotely using Remote Desktop Services

This however, did not work...

Are there any other settings I should be enabling?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

What do you mean it didn't work? Do you get a message stating that the user can't connect? Is the user in the local Remote Desktop Users group? If not, add the user to the group.

Where exactly is that GPO setting? I don't see it in the local copy of gpedit, in a W2K3 domain, or a W2K8 domain.

share|improve this answer

Usng that Group Policy setting (its name has changed over the years, depending on the Service Pack level of the ADM files... in an XP SP3 machine here I'm seeing it called "Allow users to connect remotely using Terminal Services") has been the standard way I've forced Terminal Servers to listen for connections on computers.

You don't give enough detail about the problems you're seeing.

The Windows Firewall may be preventing connections.

Assuming you are getting connected but receiving an error message about access permission the affected user probably isn't in the "Remote Desktop Users" group. You can use the "Restricted Groups" functionality in Group Policy to modify the group membership automatically.

Sometimes I see the symptoms described in this article when connecting to Windows XP machines, as well. (The client gets "The terminal Server has ended the connection." and the server machine logs "The RDP protocol component "DATA ENCRYPTION" detected an error in the protocol stream and has disconnected the client." in its event log.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.