Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a new Zimbra server (Release 5.0.18_GA_3011.UBUNTU8 UBUNTU8 FOSS edition) running and it was working great until we changed the host name following documented procedures. Now the server is not listening on port 110 anymore on the proper interface. It is listening on tcp6 under localhost, but not the public IP or even 0.0.0.0 as port 25 does. We have tried re-provisioning the server ports to no avail. We looked in all the config files and everything looks correct. Mail is flowing and ending up in mailboxes, so the mailboxd service is functioning fine. The imap/pop proxy is turned off as required. I don't know what we are missing here. Any help would be appreciated. Thanks.

share|improve this question
    
You say that the proxy is turned off as required. Was proxy configured on the box at any point? It may help to post the output of "zmprov gacf|grep zimbraPop3" –  Alex Mar 10 '10 at 17:51
    
Alex - thank you for your response. We did figure it out (see below), but thanks for the help! We did run that command BTW and saw that 110 was bound, just to the wrong interface. –  John Virgolino Mar 10 '10 at 19:13

1 Answer 1

up vote 0 down vote accepted

Well, we found the answer. It was a DNS related issue, kind of. The hosts file had mail.ourdomain.com resolving to 127.0.0.1 instead of the outside IP address interface. So when Zimbra started up it used 127.0.0.1 as the binding address. Looking at the jetty.properties file confirmed this: zimbraPop3BindAddress=mail.ourdomain.com. That is why a netstat -ln showed port 110 bound to 127.0.0.1. We couldn't figure out how to modify the jetty configuration to use a different bindaddress setting (the config kept getting overwritten during restart), so we changed the hosts file to resolve mail.ourdomain.com to only the outside ip address. After restarting the services, the proper port was bound and users were able to connect with pop3 again.

It would be nice to know how to change the jetty configuration as well (any takers?), but for now it is working as desired.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.