Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Does anyone know if there is a root cause and solution to the OS X 10.6 Samba issues? We are seeing very slow connects from 10.6.2 to Windows Server 2003 via samba.

(smbclient connects fast every time)

Any suggestions?

share|improve this question
    
What is Leapord? –  Peter Mortensen Mar 11 '10 at 8:07

2 Answers 2

Mac OS X's TCP delayed ack implementation's default mode of operation seems to run afoul of some SMB servers on some networks. Do this:

$ sysctl net.inet.tcp.delayed_ack

...and see if it's set to 3 (the default, at least as of Mac OS X v10.6 "Snow Leopard"). If it is, try setting it to 0 (off):

$ sudo sysctl -w net.inet.tcp.delayed_ack=0

...and re-run your test. You may need to unmount any mounted SMB shares and re-mount them, so that you're creating new TCP connections to the server after changing your Delayed Ack setting.

If that solves the problem, you can make that change automatically take effect on every boot by creating a file:

/etc/sysctl.conf

and have it contain the line:

net.inet.tcp.delayed_ack=0
share|improve this answer
    
This fixed it for me, thanks! –  EightyEight Aug 23 '10 at 15:34
    
Didn't do anything to improve it for me, unfortunately. Still having the problem. –  James Moore Sep 17 '10 at 15:28

Is OSX bound to the AD or running stand alone. If its part of the AD I would check your directory services logs (under Application->Utilities->Console). I have seen issues where OS X guest are waiting to a connection to a no longer present Domain Controller to timeout before they connect.

The Second thing to check is the DNS lookup. Samba can use both NetBIOS and DNS to find hosts to connect to, typically DNS is the quicker of the two. If it is a name resolution issue you should be able to get and idea of it by connecting directly via the IP address.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.