Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Somehow my MetaBase.bin is corrupted on my Windows XP machine. I've attempted to uninstall and reinstall IIS numerous times. I did see the post here which I made sure to follow exactly however after uninstalling IIS the Inetserv folder does not get completely removed it is left with.

MetaBase.bin aqadmin.dll aqueue.dll seos.dll

Anytime I delete those files they immediately reappear.

When I attempt to reinstall IIS I am presented with:


[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:ProcessSection.[register_iis_core_dcom].Start.
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=74...
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=76...
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=86...
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:Calling ProcessSection:register_iis_core_dcom:End.return=1
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=47...
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:ProcessEntry_If:check if [51=6]
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=5...
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:Calling ProcessSection:register_iis_core_fillmetabase:Start.
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:ProcessSection.[register_iis_core_fillmetabase].Start.
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=106...
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:SetAdminACL:(/)Start.
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:SetAdminACL:Write the new security descriptor to the Metabase:Start.
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:SetAdminACL:  At this point we have already been able to write basic entries to the metabase, so...
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:SetAdminACL:  If this has a problem then there is a problem with setting up encryption for the metabase (Crypto).
[3/10/2010 19:3:2] OC_COMPLETE_INSTALLATION:iis_core:WriteSDtoMetaBase:Start.
[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:MyMessageBox: Title:IIS Setup Error, Msg:CoGetClassObject

0x80080005=Server execution failed

[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:WriteSDtoMetaBase:End.  Return=0x80080005
[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:SetAdminACL:Write the new security descriptor to the Metabase:End.
[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:SetAdminACL(/):End.
[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:MyMessageBox: Title:IIS Setup Error, Msg:Do you want to retry?
[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=86...
[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=2...
[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:------------------
[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:CallProcedureInDll(C:\WINDOWS\system32\inetsrv\iislog.dll): DllRegisterServer
[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:iOleInitialize: Succeeded: 0.  MakeSure to call OleUninitialize.
[3/10/2010 19:3:32] OC_COMPLETE_INSTALLATION:iis_core:CallProcedureInDll: Calling 'DllRegisterServer'.Start
[3/10/2010 19:4:3] OC_COMPLETE_INSTALLATION:iis_core:MyMessageBox: Title:IIS Setup Error, Msg:Error calling procedure 'DllRegisterServer()' in file 'C:\WINDOWS\system32\inetsrv\iislog.dll'.

0x8000ffff=Catastrophic failure

[3/10/2010 19:4:3] OC_COMPLETE_INSTALLATION:iis_core:!FAIL! 
[3/10/2010 19:4:3] OC_COMPLETE_INSTALLATION:iis_core:CallProcedureInDll: Calling 'DllRegisterServer'.End.FAILED. Err=8000ffff.
[3/10/2010 19:4:3] OC_COMPLETE_INSTALLATION:iis_core:------------------
[3/10/2010 19:4:3] OC_COMPLETE_INSTALLATION:iis_core:MyMessageBox: Title:IIS Setup Error, Msg:Do you want to retry?
[3/10/2010 19:4:3] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=86...
[3/10/2010 19:4:3] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=84...
[3/10/2010 19:4:3] OC_COMPLETE_INSTALLATION:iis_core:MigrateInfSectionToMD:(CORE_REG_IIS3_UPGRADE)Start.
[3/10/2010 19:4:33] OC_COMPLETE_INSTALLATION:iis_core:MyMessageBox: Title:IIS Setup Error, Msg:CoGetClassObject

0x80080005=Server execution failed

[3/10/2010 19:4:33] OC_COMPLETE_INSTALLATION:iis_core:MigrateInfSectionToMD(CORE_REG_IIS3_UPGRADE):End.
[3/10/2010 19:4:33] OC_COMPLETE_INSTALLATION:iis_core:...ProcessEntry:100=84...
[3/10/2010 19:4:33] OC_COMPLETE_INSTALLATION:iis_core:MigrateInfSectionToMD:(CORE_REG)Start.
[3/10/2010 19:5:3] OC_COMPLETE_INSTALLATION:iis_core:MyMessageBox: Title:IIS Setup Error, Msg:CoGetClassObject

0x80080005=Server execution failed

And in the event viewer

Event ID: 7023 The IIS Admin service terminated with the following error: The data is invalid.

Event ID: 10010 The server {A9E69610-B80D-11D0-B9B9-00A0C922E750} did not register with DCOM within the required timeout.

share|improve this question

Looks like the problem occurred when trying to write the Cryptographic information in the Metabase i.e. iis_core:WriteSDtoMetaBase:Start. I suggest you uninstall IIS. Rename the MachineKeys i.e. machinekeys those are starting with c23 and 7a4. Then try reinstalling IIS.

Hope this helps.

share|improve this answer
This doesn't seem to be doing anything (I saw similar instructions to this else where tried renaming the entire Crypto folder in all users) it recreated folders but never created anything in the machine keys folder. I tried it again but this time uninstalling IIS and deleting only the machine keys folder and then rebooting and reinstalling again. – Chris Marisic Mar 11 '10 at 13:40
install logs are exactly the same except for date stamps, at this point I don't even have a machine keys folder. Is there some proper way to fix the machine keys first? – Chris Marisic Mar 11 '10 at 13:55
The MachineKeys folder is in C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys. You don't have to rename the Crypto folder. Just rename the files as mentioned earlier and that should be good. – Vivek Kumbhar Mar 11 '10 at 14:57

System restore actually worked to resolve this... surprisingly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.