Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I purchased a VPS account (centos-5-x86_64) from Hostgator mainly for the purpose of setting up an online Subversion Server. This is the first time I am managing a VPS and my linux skills are not so great, but I have basic knowledge of the OS and have been using it on and off as desktop from last few years.

So after foxing through a few tutorials online, as the first step I logged in using SSH root account provided by Hostgator and tried to run,

yum install mod_dav_svn subversion

As it turns out my account has Cpanel/WHM and since it some concept of easy apache straight forward procedure of yum install mod_dav_svn subversion won't work.

After that I found out how it can be worked out by compiling the source and stuff. But the whole procedure looked long and scary. [I am just a linux nub]. so I decided I would just skip whole apache integration stuff and just access the server using svn:// protocol, anyways that's how I configure svn on our LAN.

So I installed subversion using

yum install subversion

It installed fine.

Then I created a folder /svn_repos/testproject

and ran

svnadmin create /svn_repos/testproject/

No Problems

Using vi I changed svnserve.conf and passwd files for the repository and added a user with my name. Anonymous users don't have any access, authenticated users have write access.

Then I started svnserve using

svnserve -d

then in same terminal window

svn list svn://localhost/svn_repos/testproject

Asks for authentication for realm, provided root password then for svn username and password. Provided both. The command returns nothing but exists properly. Returns nothing is understood I didn't import anything.

But if try to access svn remotely using in another terminal:

svn list svn://ip.add.of.server/svn_repos/testproject svn: Can't connect to host 'ip.add.of.server': Operation timed out

Is what I get.

Parallels Power Panel that I got from Hostgator reports that:

The firewall is not active now. To activate the firewall, choose one of the firewall operation modes.

So if firewall is not running and I can access svn using localhost, why the operation is timing out when I try to access svn from a remote machine?

Experienced network admins please help.

Thanks in advance. Also please suggest a good book which gives detailed information on configuring Dedicated servers + WHM and CPanel.

share|improve this question

1 Answer 1

did you try to go into WHM as root and configuring easy_apache to install mod_dav_svn. i also have a centos VPS with WHM, and from what i remember it had mod_dav in the install list.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.