Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've used apt-get to install Subversion and SQLite on my Ubuntu VPS, however, I'm getting this error when I try to use svn:

svnadmin: SQLite is required to be compiled and run in thread-safe mode

Does anyone know why this might be happening? I originally tried to compile sqlite and subversion from source before switching to the ubuntu packages - could this be the issue perhaps?

share|improve this question
Show us the output of "ldd $(which svnadmin)", please. –  Jonathan Matthews Mar 11 '10 at 15:22

1 Answer 1

I had the same problem. The output of ldd $(which svnadmin) | grep sqlite is libsqlite3.so.0 => /usr/local/lib/libsqlite3.so.0 (0x0062d000).

/usr/local/lib/libsqlite3.so.0 is a symlink to libsqlite3.so.0.8.6 and this file was installed via apt-get as part of the "sqlite"-package.

The problem was that, as svn complained, my version of libsqlite3.so was not thread-safe. So I replaced it with the version from http://www.sqlite.org/download.html. This actually worked.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.