Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to run a rather large query that is supposed to run nightly to populate a table. I'm getting an error saying Incorrect key file for table '/var/tmp/#sql_201e_0.MYI'; try to repair it but the storage engine I'm using (whatever the default is, I guess?) doesn't support repairing tables.

how do I fix this so I can run the query? We are under pressure to get this table loaded for a client.

share|improve this question

1 Answer 1

That's not an actual table of yours, that's a temporary table created by the db to do some work. There's probably a left over tmp table file from a previous operation that's conflicting with whatever you're trying to do now. I'd suggest just stopping the server and running rm /var/tmp/*.MY{I,D}.

share|improve this answer
    
I tried that and it said there were no files like it, but I'm still getting that same error. –  Wayne M Mar 12 '10 at 0:41
    
The error seems to be because the tables that I'm joining and running transformations on has thousands upon thousands of records. But there's no way to trim it down or modify the query, so I'm stuck on how to fix the error without changing the query or the data. –  Wayne M Mar 12 '10 at 4:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.