Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I keep getting this error:

No cURL data returned for https://XXX.XXXX.XXX:XXXX [0] SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

I am not sure, or I could say, I dont know what is this problem. And how to solve this? Please help!

share|improve this question
add comment

5 Answers

The error is fairly clear. Essentially what is happening is that the cert on the remote end is either self signed, or signed by an authority that wget isn't recognizing. You can pass the following command while invoking wget to get it to ignore cert errors:

--no-check-certificate
share|improve this answer
    
You mean put this line on m curl call? I am using php and very new to curl, could you explain and if possible show some sample code?? –  deadman Mar 12 '10 at 5:10
2  
Well, this is merely a workaround and no real solution. If you are using ssl protected connections you must check these certificates and NOT just disable the checks.. One could use extremly outdated and broken certs and you would not recognize this with not using the cert check! Otherwise we could change back to selfsigned certs or non protected connections if we were so lazy not to use the cert checks. –  Comradin Jun 10 '10 at 11:19
add comment

You can also use the --insecure option to bypass SSL verification

share|improve this answer
3  
No, --insecure is for fools, hence the name. If you're using SSL/HTTPS, you probably do NOT want insecure transactions. –  user95688 Sep 23 '11 at 15:34
    
Is it foolish to test a hosting transfer before DNS changes SSL: certificate subject name 'www.mysite.co.nz' does not match target host name '123.4.5.6' –  Petah Aug 21 '13 at 4:55
add comment

Curl is objecting to the SSL certificate provided by the HTTPS server. Assuming the cert is valid in the first place, you may need to add the authorizing servers to the certificate chain in your curl-ca-bundle.crt.

share|improve this answer
    
I already added to my server, now, how do I chain in my curl-ca-bundle.crt? Btw, I am using php –  deadman Mar 12 '10 at 5:09
add comment

protected by EEAA Aug 7 '13 at 4:34

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?