Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Rails app running under mongrel as a windows service on a Windows Server 2003 installation.

I'd like to automate deploying new versions of the app from my Ubuntu dev server.

Cygwin is installed on the Windows server for this purpose. I can connect in via ssh and net stop servicename but net start servicename doesn't bring the service up. My initial thoughts were maybe there are windows-specific paths involved in mongrel::service and under a cygwin environment it chokes?

Any help would be appreciated!

share|improve this question

4 Answers 4

up vote 2 down vote accepted

Have you tried it using a different command line util like sc.exe?

share|improve this answer
    
This worked like a charm. Thanks! –  cpm May 5 '09 at 18:20

Does the service start when you try it through the services GUI/MMC? If so then perhaps you need to take a second look to verify that your using the right service name.

share|improve this answer
    
It works fine via GUI or when I "net start|stop" from cmd.exe. And, the service stops when I run "net stop" over SSH. It's just "net start" over SSH that doesn't work. –  cpm May 1 '09 at 3:43

Not sure if this is the same problem I've had with sshd, but make sure you only have 1 cygwin dll laying around your system. If there is more than one in the path it might be causing problems. With sshd I couldn't even get the service to start.

share|improve this answer
    
Thanks for the try, but I don't think that's what's going on. This is the first time Cygwin or anything even remotely related to Cygwin has been installed on the machine, and sshd itself is running without problems. –  cpm May 1 '09 at 16:13

Consider trying a stand-alone SSH server for Windows, like VShell or freeSSHd.

I remember using copSSH a while ago with good results.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.