Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have two .vbs scripts that are run by our Task Scheduler that have suddenly stopped working for no reason we can fathom. We haven't significantly altered our system configuration in the last 24 hours, and the scripts have run without a hitch for months.

According to the Task Scheduler the scripts just keep running and never stop, which is never the case. I stopped all running versions through the Scheduler and manually attempted to run one of the .vbs scripts. I got the following error message:

Line: 15
Error: The system cannot locate the resource specified.
Code: 800C0005
Source: msxml3.dll

Line 15 (or 16 to be more accurate - line 15 itself is blank, but so is line 1) is: xml.Send

Would could have suddenly caused this? Looking in system32\ and sysWOW64\ shows that msxml3.dll exists.

Anybody got any ideas?

Thanks a lot!

share|improve this question

1 Answer 1

up vote 2 down vote accepted

What is it trying to send to? the xml.send method is used to make a http/https request. The error indicates it can no longer make the request. Perhaps the server is down or something has been changed. Try and open up a web browser and manually connect to the server the script is trying to access.

share|improve this answer
    
Woot! Our IIS bindings had been altered meaning the script couldn't find the site it was looking for. A few quick changes and it's running perfectly again. I was barking up completely the wrong tree! Thanks for your help. –  Django Reinhardt Mar 12 '10 at 17:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.