Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I frequently need to install a package on the global zone for a quick test on a development box.

When there are multiple prompts for one package I have to answer them for each zone. If the zone is not running then I need to wait for the zone to start up, answer the prompts, etc.

This is particularly annoying when if I'm getting packages from http://www.sunfreeware.com and using the pkg-get utility which nicely pulls in dependencies for you.

Can I disable the zones temporarily? I haven't found a way to do this.

share|improve this question

1 Answer 1

Just tell pkgadd to install in the global zone only by uncommenting this line in the pkg-get.conf file:

PKGADDFLAGS=-G

If using pkgadd, add this -G flag to the command line.

If for some reason, you really want to disable all non global zones, a quick (and dirty) way is to move temporarily /etc/zones to /etc/zones.disable.

share|improve this answer
    
Thanks. I'd read about the -G flag but had forgotten all about it. –  Gary Mar 16 '10 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.