Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Greetings all, I'm having a very odd error with a windows 7 ultimate x64 system.

The network system setup is as follows:

2x XP Pro 32 Bit machines 1x Vista ultimate x64 machine 2x Windows 7 x64 Ultimate machines all chained into 1x 16 port netgear prosafe gigabit switch, the windows 7 & vista machines are duplexed. Also there is a router (netgear Rangemax) chained off the switch

I am basically using one of the windows 7 machines to host storage & stream media to other machines. To this end i have put 2x 3tb hardware RAID 5 arrays in it and assorted other spare disks which i have shared the roots of.

The unusual problems start when i am getting Access denied, Please contact administrator for permission blah blah blah when trying to access both of the RAID 5 arrays but not the other stand alones.

I have checked the permission settings, i have added everyone to the read permission for the root, i have tried moving things into sub directories then sharing them. I have tried various setting combinations in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa and always the same. I have tried flushing caches all round, disabling and re-enabling shares & sharing after restart as well as several other things & the result is always the same... No problem on individual drives but access denied on both the RAID arrays from both XP & Vista & Windows 7 machines. One interesting quirk that may lead to an answer is that there is no "offline status" information regarding the folders when you select the RAID 5s from a windows 7 machine yet there is on the normal drives which say they are online. It is as if the raid is present but turned off or spun down but as far as i was aware windows will spin an array back up on network request and on the machine itself the drives seem to be online and can be accessed.

Have to admit this has me stumped. Any suggestions anyone?

Thanks in advance for any fellow geek assistance.

K.A.I.N

share|improve this question

2 Answers 2

You might be running into what is effectively a UAC problem with the user accounts that are trying to map the shares. Here's a KB article describing a fix for Vista machines, but it will also work the same on your Windows 7 machines.

The fix is to basically create/update the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Look for the LocalAccountTokenFilterPolicy value. If it's not there, create it as a new DWORD value. Then set it to 1.

share|improve this answer
    
UAC problems wont affect XP though –  Tom Mar 21 '10 at 2:54
2  
They do when XP is the client connecting to a Vista+ "server" share. It's the server that validates the client credentials and by default in Vista and beyond, incoming network credentials are not elevated. That's what this registry value changes. –  Ryan Bolger Mar 21 '10 at 7:14
    
Thanks, learned something new. +1 ;) –  Tom Mar 22 '10 at 20:30

Question, if you dont have any data on these drives yet.

For testing purposes, can you wipe the drives and make some smaller partitions or smaller Raid arrays.

Are all the machines updated with the latest windows updates? Assuming yes, but, just asking

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.