Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Fusion 2.0.6 (196839) on an iMac running 10.6.2 with 3 user accounts (1 Administrator). I have Fusion set up to share the Guest OS, and it's been working splendidly for nearly a year. Within the Guest OS (Windows XP PRO), there are also 3 user accounts (1 Administrator).

Last night I went to back up my VM to an external drive, and to minimize the file size and transfer time, I deleted all Snapshots but the most-recent one. I then backed up the VM externally (28.23 GB).

Today, one of my users tried to launch the Guest OS from within her user account, and received the following error message:

"File Not Found: Windows XP Pro-000006.vmdk

"This file is required to power on this virtual machine. If this file was moved, please provide its new location."

My two choices are Cancel and Browse.

When I browse, I can locate the Windows XP Pro-000006.vmdk file, which appears to be contained within the VM file (Windows XP Pro.vmwarevm). However, it still won't launch from a non-Admin user account. If I view the package contents of the VM file from the user account, the above file is present and appears to be created upon each launch of the Guest OS.

If I go back to my Administrator account on the Mac and then launch Fusion, the Guest OS works perfectly for all 3 user accounts within XP Pro.

I have tried to delete the Guest OS from Fusion's Library within the problem user account, then re-connect it to that Library, but the result is the same. The Guest OS data integrity is 100% -- but is accessible only from the OS X Administrator account.

This problem only surfaced after deleting several older Snapshots. Again, the data is there, the Guest OS powers up normally in the Mac's Administrator account, but persistently returns the above error when attempting to power on from a non-Admin account on the Mac.

I'm not sure how this is affecting the error, but when I look at Hard Disk Settings, the "unable-to-locate" file is the filename of the virtual HD. I don't want to make any changes to my (working) VM without any advice from the knowledgeable people on this forum.

Any help will be greatly appreciated, thanks!

Attachment

share|improve this question
add comment

2 Answers

I would recommend starting by checking the access right to the file and the folder the file is located in. Can the user actually find and read the file?

share|improve this answer
add comment

Have you looked at the permissions of the file compared to the other files? A simple check is to use "get info" from Finder for that file and another similar one and see if they differ. Otherwise you may need to use the Terminal application to look at the permissions from the command line.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.