Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to configure a Management Agent (MA) for Global Address List (GAL) sync in FIM 2010. I cannot move to the next step from "Configure GAL" because of an error message saying "It appears this forest is not exchange enabled". Nothing I change on "Configure GAL" step is changing this behavior.

I'am configuring a standalone test lab. I have a Windows 2008 R2 x64 Server, promoted to a DC and SQL 2008 SP1 installed, DNS is also running locally. I have tried to install Exchange 2010 and 2007, but there is no difference.

AD MA works fine.

Any ideas what did I screw up?

UPDATE:

@Sam pointed out that i might actually did not install exchange, so I did it again now carefully reading messages. I have went through all the prerequisites and have an all green installation no even warnings. Oh man, it is not a straight forward setup.

It did not help, still the same effect, but I have noticed new message box "The LDAP service is unavailable" when entering the "Configure GAL" step. I can configure AD MA without errors and run sync on that, so LDAP should run ok.

UPDATE:

I have used AD MA with Exchange enabled on "Extensions" setup step. Works ok, provisions contact and they are seen in GAL... while GAL MA has the same problems. Any thoughts?

share|improve this question
    
You say you have tried to install Exchange, did you succeed? If you have not installed exchange then you forest will not be Exchange Enabled –  Sam Mar 15 '10 at 15:36
    
There were some warnings, but I did not need the Exchange (only the AD modification part) so i have ignored them. I'll do Exchange installation again, and check them up. –  WooYek Mar 15 '10 at 16:46
add comment

2 Answers 2

I was having the exact same issue. I think installing the FIM 2010 updates (available through windows update) solved the issue.

I wrote the following as a summary:

http://setspn.blogspot.com/2010/05/fim-2010-rtm-gal-sync-ma-creation-ldap.html

share|improve this answer
add comment

What i did was add the FQDN of the forest on the "Connect to Active Directory Forest" section of the GAL MA and used the full UPN of the user i.e Administrator@contoso.local and left the domain blank.. All then worked

share|improve this answer
    
Thx, I'll check that out. –  WooYek Apr 26 '10 at 8:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.