Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set the caller id number for an outbound call.

My asterisk .call file looks like this:

Channel: SIP/flowroute/1234567890
Context: test
Extension: 1234567890
Priority: 1

Here's my extensions.conf:

[test]
exten => _1NXXXXXXXXX,1,Set(CALLERID(num)=8005552222)
exten => _1NXXXXXXXXX,n,Dial(SIP/${EXTEN}@flowroute)
exten => _1NXXXXXXXXX,n,Playback(hello-world)

When I receive the call, the caller id number is 1-206-445-6979, even though the CDR log has both src and clid set to 8005552222. I'm using flowroute as my carrier. Is there something wrong on their side?

share|improve this question

2 Answers 2

Your config is correct. Your carrier is likely preventing you from setting an arbitrary CID number; check with them.

share|improve this answer
    
I agree this is likly the problem. With our carrier we had to sign an agreement with them that allowed us to set our outbound caller id. They do this to prevent telemarketing compaines from playing with their numbers and confusing the parties being called. Contact your carrie and they should be able to help you get setup so you can set this. –  Richard West Mar 16 '10 at 2:45
up vote 3 down vote accepted

Here's how I got this working:

.call file:

Channel: SIP/flowroute/1234567890
CallerID: "Test" <8005552222>
Context: test
Extension: 888
Priority: 1

extensions.conf:

[test]
exten => 888,1,Playback(hello-world)

Note that the extensions.conf context does not include a dial application. In fact, when it was included two outgoing calls were placed with some very strange results.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.