Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm stuck. After setting up gitosis, cloning gitosis-admin for the first time results in the following:

$ git clone ssh://git@myserver.com:gitosis-admin.git
Initialized empty Git repository in c:/path/to/my/repo
Using username "git-upload-pack 'git".
fatal: The remote end hung up unexpectedly

Anyone ever experience this problem? Troubleshooting ideas?

share|improve this question
    
You could try gitolite. This is a new project based on the idea of gitosis, but it's actively maintained. gitosis hasn't really been worked on since 2008. –  davr Mar 16 '10 at 4:08
add comment

2 Answers

up vote 1 down vote accepted

Turned out this was an SSH issue. Disabling password authentication on the server revealed that running the clone command with git-bash was failing with the following output:

FATAL ERROR: Disconnected: No supported authentication methods available

Stumbling upon this thread led me in the right direction. My GIT_SSH env var was set to use plink. Because of this, git used putty to connect via ssh (despite me expecting openSSH)

Gitosis requires the use of an agent to store your keys for exchange. I started up pageant and BAM, it worked.

share|improve this answer
add comment

Actually your real problem was the git clone ssh://git@myserver.com:gitosis-admin.git being in an invalid format. You should of either removed the ssh:// or changed the last : to a /. You probably fixed this on a future attempt without realizing it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.