Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a munin-master and munin-node installed on same server (Ubuntu 9.10 server).

Most pre-installed plugins work well but the following plugins are with blank graph:

Memcached bytes used
Memcached connections
Memcached cache hits and misses
Memcached cached items
Memcached requests
Memcached network traffic
MySQL Queries Cache Size

I run the following 3 script in terminal and results were ok.

/etc/munin/plugins/memcached_bytes
/etc/munin/plugins/memcached_counters
/etc/munin/plugins/memcached_rates

But when I tried the command below after "telnet localhost 4949"

fetch memcached_bytes 
# Unknown service
etch memcached_bytes_
# timeout pid 28009 - killing...done

Does anyone know the reason?

share|improve this question
    
Can you post the output from: munin-run memcached_bytes --debug –  Tom Feiner Mar 18 '10 at 21:07

1 Answer 1

up vote 2 down vote accepted

Did you restart munin-node after putting the memcached plugins in the plugin directory? Are any of them listed if you run 'list' when connected with telnet?

Any of the memcached plugins I've seen need the port and ip included in the name of the plugin, like the if_ scripts, where there's just symlinks into /etc/munin/plugins like:

# ls /etc/munin/plugins/memcached_bytes_127_0_0_1_11211 
lrwxrwxrwx 1 root root 39 2010-02-01 05:56 /etc/munin/plugins/memcached_bytes_127_0_0_1_11211 -> /usr/local/share/munin/memcached_bytes_
share|improve this answer
    
@theothererreceive, munin-node had been restarted I even run "sudo -u munin munin-cron" but no luck. Looks like there is no need to put host and port into memcached plugins link according to the installation guide come with the script. –  jack Mar 16 '10 at 23:16
    
@theothererreceive, the plugin i used is from munin-monitoring.org/browser/trunk/plugins/node.d/memcached_.in –  jack Mar 16 '10 at 23:18
    
I used a link like 11211_memcached_new_bytes -> /usr/share/munin/plugins/memcached_new_ and then configured separate port configs in the plugin-conf.d. I wish I could make the magic linking as described here work. It would be much more elegant. –  rfay Jun 23 at 17:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.