Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A client has given me a Plesk account to install his PHP app in, but the PHP memory limit is only 32M and I'd like to increase it. I tried to find this setting on the admin panel but couldn't :(

share|improve this question
add comment

4 Answers

I don't know if your admin panel allows you to access this file, but the usual way to increase PHP memory limit is by changing the memory_limit option in the php.ini file.

share|improve this answer
add comment

You may adjust that value via .htaccess file.

php_value memory_limit 64M
share|improve this answer
    
nice, didn't know this was possible! –  MatToufoutu Mar 16 '10 at 18:49
    
Unless your Plesk hosting company has disabled .htaccess (some do), it should work just fine. Make a phpinfo(); page in the same directory as the new .htaccess file to see if the change has taken effect. –  Joe Mar 16 '10 at 20:03
    
As mentioned by Embreau, this doesn't work if Fast-CGI is enabled, but editing the main php.ini works in that case. –  romkyns Feb 10 '11 at 16:09
add comment

There is no way to update it on the control panel.

What you need to do is to create a file called : vhost.conf

This file must be located in :

/var/www/vhosts/domain.com/conf/

Inside this file, add (and change domain.com) :

<Directory /var/www/vhosts/domain.com/httpdocs/>
php_value memory_limit 64M
</Directory>

As root, run the following :

/usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost --vhost-name=domain.com

Restart Apache

Please note that if you use Fast-CGI this won't work, you would need to change it within the main php.ini.

EDIT: Added path to vhost.conf file

share|improve this answer
    
This is (almost definitely) a shared hosting server. Rashal won't have the access to run that command. I agree however, that your answer would work perfectly. –  Joe Mar 16 '10 at 20:13
    
Being a shared server, he will have to ask his web hosting company. –  Embreau Mar 16 '10 at 20:50
add comment

I use plesk 10 on my own shared Linux server and this works:

ini_set('memory_limit', '64M');

Makes life easy because you can just do it where a script really should take up lots of RAM. Might need some changes depending on your server but for me it runs out of the box.

share|improve this answer
    
Just to clarify: This is a PHP statement, and you can just add it to your PHP scripts. –  Adrian Lang Nov 22 '12 at 15:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.