Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i've installed postgres on ubuntu and am trying to do a pg_dump but get the error message:

"pg_dump: [archiver] WARNING: requested compression not available in this installation -- archive will be uncompressed"

i've read that this is because i didn't install zlib along with postgres.

how can i install zlib for postgres now that postgres is already installed?

thanks.

EDIT: command:

pg_dump myDb -U myUser --schema=public --format=c --compress=9 > somefile.dmp

it's because of the --format=c, but i would like to have it compressed (which custom (c) does by default).

share|improve this question
    
Can you post the command line you're using? – James Mar 17 '10 at 9:30
up vote 1 down vote accepted

It's not because of the --format=c, it's because of the --compress=9. You can use custom format without compression.

How did you install your PostgreSQL? If it was from the standard Ubuntu packages, it should have compression. If it was from source, you need to recompile with zlib available - remember to have the developer package. Normally, this would only happen if you explicitly configured it with "--disable-zlib".

share|improve this answer
    
yes compiled from source, will try re-compiling. thx. – pstanton Mar 17 '10 at 19:59

Folks, this is solved for after updated zlib-devel in centos. - Mohammed Azfar

share|improve this answer
1  
The poster has an Ubuntu system, centos doesn't really apply. – sysadmin1138 May 17 at 20:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.