Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This issue has been occupying my work for the last few days and I will be understating when I say its driven me up the blasted walls.

Essentially, I can ping and tracert the domain and the subdomains and All three mentioned point to ip address

About 4 days ago, when we registered the domain "" suddenly all external connection to the mail server from outside was lost. Not just mail, but other http based port-forwarded or natted services (such as camera surveillance and pbx services).

I tried good old telnet (I'm a linux user) and I get the following output:

telnet> o 25
telnet: Unable to connect to remote host: No route to host

Tracert gives me:

traceroute to (, 30 hops max, 60 byte packets
1 (  0.869 ms  0.944 ms *
2  * * *
3  * * *
4  * * *
5  * * *
6  * (  33.875 ms  39.187 ms
7  * * *
8  * * *
9  * * *

10 * * * 11 * * ( 67.621 ms

I am stumped. Other friends from all around the world can telnet no problem. What could have possibly happened to make telnet/smtp/pop/imap/http access stop?

Please bear in mind I'm primarily a developer but I [am under the delusion] that I can carry my weight in IT administration :)


share|improve this question

Registering a domain should have no effect on you being able to connect by IP address. Domains simply provide a lookup service via DNS, connecting directly by IP address totally and completely bypasses DNS.

Your connection issues are either one of those amazing coincidences or perhaps when you configured the new domain you made an accidental change which has caused it.

For what it's worth Nmap shows all of your services up and available and I can telnet to your mail server.

So two thoughts spring to mind - either you routing is screwed up or your server is blocking your IP address.

share|improve this answer
How can I check routing? Tracert is routing OK (or so it seems) I called the ISP and they're not blocking my address or any outgoing traffic on port 25. – Mustafa Ismail Mustafa Mar 17 '10 at 15:31
@Mustafa Might be an idea to confirm this by running nmap – Jon Rhoades Mar 18 '10 at 3:06

I don't totally understand your problem. You say:

suddenly all external connection to the mail server from outside was lost

But later you mention others from outside can access the server and I can certainly reach it from here. So, is the problem simply that you can't reach the server by its DNS name from itself? Or is the connectivity a problem from all computers on your local network? Or?

Regardless, you obviously have name resolution working but when you do that telnet to port 25 you get a "no route to host" which almost always indicates a network problem, usually indicating that something is set incorrectly on that machine's NIC. Is your subnet mask and gateway set correctly on the computer?

share|improve this answer
I'm trying to reach it from outside our office network (home in this particular case, but I've tried it at other locations and its the same) so I don't think the subnet mask & gateway are essential here. The issue does not exist on the local network, its from outside. And again, this happened suddenly; It was working perfectly well before. – Mustafa Ismail Mustafa Mar 17 '10 at 15:29
OK, so it would be fair to say then that it is accessible from some external hosts but not from others since you mentioned it works fine for friends from all around the world and I can reach it from here just fine too. Since DNS works from the places where you can't telnet, we can rule that out. The only thing left is an odd connectivity issue which makes me think you're just doing something unusual when testing from outside. Maybe a firewall blocking access from your test machines or something like that. – icky3000 Mar 17 '10 at 16:35
I gave up and took my old rusty laptop and tried things from my in-laws who happen to be with the same ISP on which the office connection is on. It works like Swiss Clockwork. Now why the heck is that? My ISP and their ISP duking it out? I can tracert and ping and resolution is perfectly fine, so what the heck could it be? Now, I know for a fact its my connection at home, but why suddenly 2-3 days ago? Thanks a lot for all the help too :) – Mustafa Ismail Mustafa Mar 17 '10 at 19:43

Another idea - maybe port outgoing connections 25 was blocked in your network or by ISP.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.