Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Help - I tried to join a workgroup but now all of a sudden I can't log into my system. I get an account not found error. Also for some reason when I click the options button on the log in screen I can't see the domain option at all.. whats going on! I can't even log in using the administrator login or anything!!

share|improve this question

closed as not constructive by John Gardeniers, EightBitTony, sysadmin1138 Oct 19 '12 at 19:46

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

8 Answers 8

If you "joined" a workgroup there will be no Domain option shown on the logon screen. You would need to have joined a domain for that to happen.

If you in fact joined a domain, did you restart the computer?

Joining a domain or workgroup would have no impact on any local account used before the change

share|improve this answer
    
If there were no local users before you "joined" the workgroup, you're locked out of your computer. If you have a network admin, please call him/her before messing with anything else. Also, you can only belong to one workgroup or domain at a time. –  Chris S Apr 15 '10 at 17:49
add comment

You should have created (and verified) a local Admin account using a Domain Account with admin rights on that system before removing it from the domain. Testing that you have local admin rights using a local account is something you should always do before messing with domain\workgroup membership changes. Knowing that now is not much use to you though.

Using password recovery tools may be possible but you might have some luck with the following - I've never tried this and it's quite likely that it wont work but it's worth a try:

Physically disconnect the PC from the network, reboot and try the "Last Known Good" boot option (press F8 as it starts up to get to the menu where you can select the "Last Known Good" option. This might now allow you to log in locally using the cached domain admin credentials. I say might because the "Last Known Good" copy of your environment is only updated after a successful log on. Since that hasn't happened in your case it should still store a system state that allows you to logon with domain credentials while disconnected from the network (which it is since you disconnected the network). If this does allow you to log in with an account that has administrator rights on the PC you can then create a local administrator account. Test that account before doing anything else. If it works you're good to go.

The machine still thinks it's in the domain at this point but the domain knows it's not so you will still want to go back and repeat the exercise of "joining" the workgroup if that's what you want to do.

share|improve this answer
    
OK I've logged in somehow using admin credentials for the local machine - however I can't set my pc to be aprt of teh domain now. I get an error saying that the DNS controller cannot be contacted.. whats going on here! –  Ali Mar 18 '10 at 5:31
    
If this works, you need to immeditely set the local admin password, and make sure the account is enabled. Then reboot the commputer, use the local account to login, plug it into the network, join it to the domain (your normal domain credientially will allow you to join the computer to the domain, limited to 10 computers by default). –  Chris S Apr 15 '10 at 17:51
add comment

You must use your local administrator credentials instead domain what you used before joining to domain.

share|improve this answer
    
THATS THE PROBLEM nobody knows what the local administrator credentials are exactly to begin with... –  Ali Mar 17 '10 at 14:04
add comment

If you have removed your computer from the domain (which you have if you have joined a workgroup), then the domain login accounts will no longer work on this machine.

You need to login with a local account, if you don't know the credentials for a local account then you are going to have to look at some alternative methods to reset these. Take a look at this article for methods on doing this. I have had the most success in the past with the Offline NT Password & Registry Editor

share|improve this answer
add comment

I did exactly the same thing with the same result. Spent a whole day trying to find a solution and came across the below website. It provides a link to download a really excellent piece of software called ERD COMMANDER (if you are locked out of your computer like I was, you will, of course, have to do this using another machine). It is a rar file and when unzipped you must save it to a cd. Before using the CD, start up the troubled machine, (In my case a laptop running XP Professional) and hold down the relevant key to allow access to bios (mine was F2). Alter the boot up order so CD drive is first on list (this means your computer will read this file first when trying to reboot). Save the changes and insert cd with ERD COMMANDER on, then shut down/restart. It will take a few minutes to read the disc, then ask you to click on which system it is to operate on (Click your Operating system) - mine was XP (it also works on NT, 2000 & Server 2003). It will then just bring up a couple of icons on screen, something like computer, networking etc, but ignore these. Click 'Start' and a list of tools comes up - you can either find the lock-wizard and reset password, or, in my case I chose the sytem restore option and rolled the system back to yesterday. When I rebooted, my domain was back and my passwords worked again. JOY!!! This has probably saved me a fortune, (as well as all my files etc.)

http://101pctricks.blogspot.com/2008/03/reset-windows-xp-password-using-erd.html

Good luck !

Angel

share|improve this answer
add comment

Hi I do not know if your problem have been solved but I like to suggest a solution. Boot your system to save mode and select the save mode with networking option, this will log you on to the local administrator's account. Wright-click my computer and select manage, select Local users and groups, click users, wright-click administrator (built-in administrator account), select set password, proceed. Put the password and confirm the password and click OK. Wright-click on the administrator and select properties uncheck the account is disabled checkbox, click apply and OK. Then you are good to go.

Good Luck.

share|improve this answer
add comment

I think you might be in over your head and should contact the person who configured the domain...

share|improve this answer
add comment
  1. Prepare pendrive
  2. (On another comp) download and run unetbootin
  3. From unetboootin download ntpasswd (or sth) and install it on the pendrive
  4. Boot from the pendrive and reset password of the local admin
  5. (Optionally) log in as admin, go to the start/accessories/system/recovery (or sth) and recover a point in time from before you disconnected the domain
  6. Login into your old, good, domain account
  7. (Optionally) log in as admin create a new local account, log in log out, log in as admin, copy your old domain profile to the new local account relog as admin and now...
  8. Disconnect from the domain again, for good. now you can log in as the new local account and enjoy your old domain profile :-)
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.