Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The power went out all of a sudden and when we tried to restart everything when it came back on - our server can't be assigned an IP? We got an error stating that the IP for the server was already in use by another system. We then shut down all systems and restarted the server but then for some reason the server was assigned an IP but no one could connect to it - after restarting the server after setting it to have a dynamically assigned ip - the server now has no ip - just 0.0.0.0 - running an ipconfig/renew or ipconfig /release has no effect.. what should we do!!

============================== OK the server somehow got the ip and only one pc on teh network can access it - however other pcs can't even ping it for some strange reason. Infact one PC which I'm trying desperately to put on the domain gives me a cannot find domain controller error. Plus when I ran an ip config on the other pcs they show a 'media disconnected' on the ipconfig even though they all have ips set up...... whats happening here?

share|improve this question
1  
who assignes the ip addresses? Start that first. WAIT until it is stable. Wait anothe r15 minutes. then start servers slowly, one by one. Then move core servers to static ip addresses. And geta DHCP host that remembers assignmenty between outages. –  TomTom Mar 17 '10 at 14:07
    
I hate to be a party pooper, but why would you have a server configured to get it's ip address via DHCP in the first place? What function or role does this server provide? –  joeqwerty Mar 18 '10 at 2:26

3 Answers 3

up vote 3 down vote accepted

What happens if you turn it off and ping the server's IP that it's supposed to have? Anything answering?

What if you remove and reinstall the network card driver?

Does the server have more than one card, or is it teamed with a second card? Redundancy? What kind of hardware is it?

Update the driver on the card?

Change the port the network cable is plugged into no the switch? Still happen? Could be the switch is confused or damaged.

Other possibility is that the network card is damaged. Can you install a third-party card?

share|improve this answer
    
RIght now it assigned it an ip but the network icon shows limited or no connectivity. I try to repair the connection and I get an error saying that 'the following failed - Renewing your ip'.. what now! –  Ali Mar 17 '10 at 14:53
    
OK now my server got an IP but I can't connect to it! If I try to set a pc on the domain I get an error saying that he can't locate a domain controller! –  Ali Mar 17 '10 at 14:57
    
Did you check the switch? Change ports it's connected to? What exactly did you do in troubleshooting, just assign the IP or did you change drivers or...? –  Bart Silverstrim Mar 17 '10 at 15:07

I've also had this problem, usually restarting the router cures it (then rebooting the systems/renewing the ip). I don't know what causes it exactly, but it probably has something to do with arp caching (or some other mystical router cache).

share|improve this answer

You need to run yourself a nmap scan, can perform a icmp/arp sweep of your subnet. Check your dhcp servers scope's and see you any overlaps in address pools. Check for a rogue dhcp server on your network, it's possible someone has connected another network device that's offering dhcp ranges that clash with your servers address allocations. This would be bad.

If you are not sure what subnets/devices are where and why, then I advise you make a network diagram. You may be surprised when you find things that you didn't even know were connected. I've been asked to trouble shoot networks and have found linksys wireless routers connected by staff on some sites, because 'they wanted wireless access in their office/floor/department'. Not good for network health. :-(

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.