Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have set up my Postfix, with TLS/SSL, correctly. Every test on the machine itself (with telnet) runs fine.

However, when I want to access the server from somewhere else, it fails.

So port 587 and the rest is blocked for some reason, but I don't really know where.

share|improve this question
So what happens when you telnet to the server? Any firewalls between you and the server? Any firewalls on the machine you are testing from? – icky3000 Mar 17 '10 at 21:55
Telnetting on the machine itself, or from home, to port 587 works without a problem. So it can't be a firewall problem – skerit Mar 17 '10 at 22:13
up vote 1 down vote accepted

Have you tried telnetting from the machine to the external IP? If it fails the firewall is blocking remote access to that port.

Can you telnet to the ports from an external machine? If not, again, firewall.

Have you tried the IP as well as the hostname? Could be a DNS issue.

share|improve this answer
Yes, executing this from my machine at home works: "telnet 587" "ehlo localhost" or "ehlo" or "ehlo" then gives me all the expected responses. – skerit Mar 17 '10 at 22:06
So in the question you said you can telnet from the machine itself. In your comment above you said you can telnet from your machine at home. Where doesn't it work? – icky3000 Mar 17 '10 at 22:13
In the mail client itself, namely thunderbird3. It tries to detect encryption on port 587 & 465, but it never finds it and defaults to port 25 with no encryption. – skerit Mar 17 '10 at 22:30
Is encryption enabled? You can usually test this through telnet - after the EHLO it should have the option to "STARTTLS" - if it's not there it's not available. Try typing "STARTTLS" if it is there and see if it errors. This is true for SMTP at least. Also, have you tried restarting the mailserver and checking the logs (/var/log/maillog usually, /usr/local/psa/var/log/maillog for Plesk) for any error messages? I've also had Thunderbird fail to find encrypted ports before on autodetect, but if I go in to "manual setup" and change the ports back it works. – James L Mar 17 '10 at 23:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.