Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a automation build server which creates nightly builds. It does this while logged off in Windows XP. This is is one domain while the server I wish to copy the builds to is in another domain (win2k3).

I can't use a network share when logged off and as soon as I try to browse manually to the server it prompts for a username/password

I am guessing the only way is to create a script/batch file which has a domain account and password for the server and runs at a scheduled time.

If there is a more elegant way, please let me know.


share|improve this question

It's a kludge but you could just add permissions on the share that exists on the second domain to allow anything running from the build computer access to it (Kind of dangerous to), why not just build it on the final machine that it needs to go to?

share|improve this answer
sadly even having a share open to EVERYONE and NTFS permissions the same, the system still prompts for user credentials. – Anonymous Mar 18 '10 at 3:57

Possible solutions off the top of my head:

  • Lock the XP machine instead of logging off.
  • Build a trust between the 2 domains so that cross-domain permissioning works.
  • Create an FTP server on the target machine with it's ftproot set to the destination directory; use a firewall to manage security (...sounds awful I know...)
  • Move the XP build machine into the same domain as the target server.

Bottom line is that a trust relationship is the "official" way of accomplishing what you want, and anything else is going to be something of a workaround.

share|improve this answer

I would not do this, a script is probably a better option, but in the name of completeness, I believe the following would work:

Go to the local security policy editor on the Win2K3 machine (secpol.msc) and navigate to Local Policies -> Security Options. Change these settings:

Accounts: Guest account status to Enabled

Network access: Let Everyone permissions apply to anonymous users to Enabled

Network access: Shares that can be accessed anonymously - add the target share name

These settings should allow anyone to update files in that share without prompting for a password.

The security-conscious out there may now be shivering with revulsion, but there it is.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.