Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

how can i completely disable STP in a Opensolaris bridge.

This bridge is connected to a Cisco Access Port and will disable the uplink port when the first BPDU arrives.

bridged[3651]: [ID 581644 daemon.warning] unexpected BPDU on rge1 from 0:xx:xx:xx:xx:b; forwarding disabled

I already disabled the transmission of BPDU Messages to the Switch by:

dladm set-linkprop -p stp=0 rge1

This solved only the problem that the access switch port goes in "error-disable" mode.

Thomas

share|improve this question
    
It seams there is no way to disable stp complete. –  quentin May 19 '10 at 9:44

2 Answers 2

Are you sure you want to disable Spanning Tree? STP is enabled for a reason to stop layer 2 routing loops, which can cause ethernet frames to loop indefinitely!

I'm not quite sure what environment your operating or what your trying to achieve, it maybe best to get to the bottom of the problem rather than a work around.

share|improve this answer

A better solution is to de-configure spanning-tree portfast and spanning-tree bpduguard enable on the Cisco port you're connected to. Without BPDU transmission and spanning-tree, you may end up having a switching loop and I've seen switching loops take networks down.

share|improve this answer
    
To err on the side of caution, I'd really do some research on those two settings before de configuring them. Perhaps talk to your network person and see what they say. If you are the network person, then get some help :-). I've just seem some very nasty layer 2 problems be caused by the misconfiguration of layer 2 protocols! –  The Unix Janitor Mar 18 '10 at 13:42
    
Removing them should (at worst) mean that it takes a while (up to a minute) for a newly-plugged-in cable to become active (removing "portfast"). The "bpduguard" is configuration option should always be enabled on a port with portfast, as what portfast does is disabling BPDU snooping, trusting the port to be a non-bridge. So, in this specific case, the configuration is safe. –  Vatine Mar 19 '10 at 11:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.